What’s Vulnerable › Vulnerabilities
CVE-2023-43322
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-28 · updated 2026-06-17
- Weakness: CWE-77
Description
ZPE Systems, Inc Nodegrid OS v5.0.0 to v5.0.17, v5.2.0 to v5.2.19, v5.4.0 to v5.4.16, v5.6.0 to v5.6.13, v5.8.0 to v5.8.10, and v5.10.0 to v5.10.3 was discovered to contain a command injection vulnerability via the endpoint /v1/system/toolkit/files/.
Affected products
- Zpesystems Nodegrid Os: from 5.0.0 before 5.0.18; from 5.2.0 before 5.2.20; from 5.4.0 before 5.4.17; from 5.6.0 before 5.6.14; from 5.8.0 before 5.8.11; from 5.10.0 before 5.10.4 — fixed in 5.0.18, 5.10.4, 5.2.20, 5.4.17, 5.6.14, 5.8.11
How to fix
Upgrade to a fixed version: Zpesystems Nodegrid Os 5.0.18, 5.10.4, 5.2.20, 5.4.17. Check the vendor advisory for mitigations.
References
- https://psirt.zpesystems.com/portal/en/kb/articles/security-advisory-zpe-ng-2023-001-12-10-2023
- https://psirt.zpesystems.com/portal/en/kb/articles/security-advisory-zpe-ng-2023-001-12-10-2023
Get alerted when CVE-2023-43322 or the next vulnerability affects your stack