What’s Vulnerable › Vulnerabilities
CVE-2023-4347: Cross-site Scripting (XSS) - Reflected in librenms/librenms
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 69.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-15 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Reflected in GitHub repository librenms/librenms prior to 23.8.0.
Affected products
- librenms: before 23.8.0 — fixed in 23.8.0
How to fix
Upgrade to a fixed version: librenms 23.8.0. Check the vendor advisory for mitigations.
References
- https://github.com/librenms/librenms/commit/91c57a1ee54631e071b6b0c952d99c8ee892e824
- https://huntr.dev/bounties/1f78c6e1-2923-46c5-9376-4cc5a8f1152f
- https://github.com/librenms/librenms/commit/91c57a1ee54631e071b6b0c952d99c8ee892e824
- https://huntr.dev/bounties/1f78c6e1-2923-46c5-9376-4cc5a8f1152f
Get alerted when CVE-2023-4347 or the next vulnerability affects your stack