What’s Vulnerable › Vulnerabilities

CVE-2023-43495

Description

Jenkins 2.423 and earlier, LTS 2.414.1 and earlier does not escape the value of the 'caption' constructor parameter of 'ExpandableDetailsNote', resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control this parameter.

Affected products

How to fix

Upgrade to a fixed version: Jenkins 2.414.2, 2.424. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-43495 or the next vulnerability affects your stack