What’s Vulnerable › Vulnerabilities
CVE-2023-43642: Missing upper bound check on chunk length in snappy-java
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-25 · updated 2026-06-17
- Weakness: CWE-770
Description
snappy-java is a Java port of the snappy, a fast C++ compresser/decompresser developed by Google. The SnappyInputStream was found to be vulnerable to Denial of Service (DoS) attacks when decompressing data with a too large chunk size. Due to missing upper bound check on chunk length, an unrecoverable fatal error can occur. All versions of snappy-java including the latest released version 1.1.10.3 are vulnerable to this issue. A fix has been introduced in commit `9f8c3cf74` which will be included in the 1.1.10.4 release. Users are advised to upgrade. Users unable to upgrade should only accept compressed data from trusted sources.
Affected products
- xerial snappy-java: before 1.1.10.4 — fixed in 1.1.10.4
How to fix
Upgrade to a fixed version: xerial snappy-java 1.1.10.4. Check the vendor advisory for mitigations.
References
- https://github.com/xerial/snappy-java/commit/9f8c3cf74223ed0a8a834134be9c917b9f10ceb5
- https://github.com/xerial/snappy-java/security/advisories/GHSA-55g7-9cwv-5qfv
- https://github.com/xerial/snappy-java/commit/9f8c3cf74223ed0a8a834134be9c917b9f10ceb5
- https://github.com/xerial/snappy-java/security/advisories/GHSA-55g7-9cwv-5qfv
Get alerted when CVE-2023-43642 or the next vulnerability affects your stack