What’s Vulnerable › Vulnerabilities
CVE-2023-43643: mXSS in AntiSamy
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-09 · updated 2026-06-17
- Weakness: CWE-79
Description
AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.
Affected products
- nahsra antisamy: before 1.7.4 — fixed in 1.7.4
How to fix
Upgrade to a fixed version: nahsra antisamy 1.7.4. Check the vendor advisory for mitigations.
References
- https://github.com/nahsra/antisamy/releases/tag/v1.7.4
- https://github.com/nahsra/antisamy/security/advisories/GHSA-pcf2-gh6g-h5r2
- https://github.com/nahsra/antisamy/releases/tag/v1.7.4
- https://github.com/nahsra/antisamy/security/advisories/GHSA-pcf2-gh6g-h5r2
Get alerted when CVE-2023-43643 or the next vulnerability affects your stack