What’s Vulnerable › Vulnerabilities
CVE-2023-43650: Non-MFA account takeover via brute-force attack on weak password reset code in jumpserver
- Severity: high (CVSS 7.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-640
Description
JumpServer is an open source bastion host. The verification code for resetting user's password is vulnerable to brute-force attacks due to the absence of rate limiting. JumpServer provides a feature allowing users to reset forgotten passwords. Affected users are sent a 6-digit verification code, ranging from 000000 to 999999, to facilitate the password reset. Although the code is only available in 1 minute, this window potentially allows for up to 1,000,000 validation attempts. This issue has been addressed in versions 2.28.20 and 3.7.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- jumpserver: from 2.0.0 before 2.28.20; from 3.0.0 before 3.7.1 — fixed in 2.28.20, 3.7.1
How to fix
Upgrade to a fixed version: jumpserver 2.28.20, 3.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-mwx4-8fwc-2xvw
- https://www.sonarsource.com/blog/diving-into-jumpserver-attackers-gateway-to-internal-networks-1-2
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-mwx4-8fwc-2xvw
Get alerted when CVE-2023-43650 or the next vulnerability affects your stack