What’s Vulnerable › Vulnerabilities
CVE-2023-43651: Remote code execution on the host system via MongoDB shell in jumpserver
- Severity: critical (CVSS 9.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-94
Description
JumpServer is an open source bastion host. An authenticated user can exploit a vulnerability in MongoDB sessions to execute arbitrary commands, leading to remote code execution. This vulnerability may further be leveraged to gain root privileges on the system. Through the WEB CLI interface provided by the koko component, a user logs into the authorized mongoDB database and exploits the MongoDB session to execute arbitrary commands. This vulnerability has been addressed in versions 2.28.20 and 3.7.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.
Affected products
- jumpserver: from 2.0.0 before 2.28.20; from 3.0.0 before 3.7.1 — fixed in 2.28.20, 3.7.1
How to fix
Upgrade to a fixed version: jumpserver 2.28.20, 3.7.1. Check the vendor advisory for mitigations.
References
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-4r5x-x283-wm96
- https://www.sonarsource.com/blog/diving-into-jumpserver-attackers-gateway-to-internal-networks-2-2
- https://github.com/jumpserver/jumpserver/security/advisories/GHSA-4r5x-x283-wm96
Get alerted when CVE-2023-43651 or the next vulnerability affects your stack