What’s Vulnerable › Vulnerabilities
CVE-2023-43659: Cross-site Scripting via email preview when CSP disabled in Discourse
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Discourse is an open source platform for community discussion. Improper escaping of user input allowed for Cross-site Scripting attacks via the digest email preview UI. This issue only affects sites with CSP disabled. This issue has been patched in the 3.1.1 stable release as well as the 3.2.0.beta1 release. Users are advised to upgrade. Users unable to upgrade should ensure CSP is enabled on the forum.
Affected products
- discourse: through 3.1.1; 3.2.0-beta1
References
- https://developer.mozilla.org/en-US/docs/Web/HTTP/CSP
- https://github.com/discourse/discourse/security/advisories/GHSA-g4qg-5q2h-m8ph
- https://developer.mozilla.org/en-US/docs/Web/HTTP/CSP
- https://github.com/discourse/discourse/security/advisories/GHSA-g4qg-5q2h-m8ph
Get alerted when CVE-2023-43659 or the next vulnerability affects your stack