What’s Vulnerable › Vulnerabilities
CVE-2023-43663: Improper Privilege Management in Prestashop
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-28 · updated 2026-06-17
- Weakness: CWE-269
Description
PrestaShop is an Open Source e-commerce web application. In affected versions any module can be disabled or uninstalled from back office, even with low user right. This allows low privileged users to disable portions of a shops functionality. Commit `ce1f6708` addresses this issue and is included in version 8.1.2. Users are advised to upgrade. There are no known workarounds for this issue.
Affected products
- PrestaShop: before 8.1.2 — fixed in 8.1.2
How to fix
Upgrade to a fixed version: PrestaShop 8.1.2. Check the vendor advisory for mitigations.
References
- https://github.com/PrestaShop/PrestaShop/commit/ce1f67083537194e974caf86c57e547a0aaa46cd
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-6jmf-2pfc-q9m7
- https://github.com/PrestaShop/PrestaShop/commit/ce1f67083537194e974caf86c57e547a0aaa46cd
- https://github.com/PrestaShop/PrestaShop/security/advisories/GHSA-6jmf-2pfc-q9m7
Get alerted when CVE-2023-43663 or the next vulnerability affects your stack