What’s Vulnerable › Vulnerabilities
CVE-2023-43701: Apache Superset: Stored XSS on API endpoint
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-27 · updated 2026-06-17
- Weakness: CWE-79
Description
Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2. Users are recommended to upgrade to version 2.1.2, which fixes this issue.
Affected products
- Apache Superset: before 2.1.2 — fixed in 2.1.2
How to fix
Upgrade to a fixed version: Apache Superset 2.1.2. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread/4dnr1knk50fw60jxkjgqj228f0xcc892
- https://www.openwall.com/lists/oss-security/2023/11/27/4
- https://lists.apache.org/thread/4dnr1knk50fw60jxkjgqj228f0xcc892
- https://www.openwall.com/lists/oss-security/2023/11/27/4
Get alerted when CVE-2023-43701 or the next vulnerability affects your stack