What’s Vulnerable › Vulnerabilities
CVE-2023-4374: WP Remote Users Sync <= 1.2.11 - Missing Authorization to Authenticated (Subscriber+) Log View
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-08-16 · updated 2026-06-17
- Weakness: CWE-862
Description
The WP Remote Users Sync plugin for WordPress is vulnerable to unauthorized access of data and addition of data due to a missing capability check on the 'refresh_logs_async' functions in versions up to, and including, 1.2.11. This makes it possible for authenticated attackers with subscriber privileges or above, to view logs.
Affected products
- frogerme WP Remote Users Sync: before 1.2.12 — fixed in 1.2.12
How to fix
Upgrade to a fixed version: frogerme WP Remote Users Sync 1.2.12. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wp-remote-users-sync/trunk/inc/class-wprus-logger.php#L117
- https://plugins.trac.wordpress.org/changeset/2946667/wp-remote-users-sync#file130
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2e87cfc4-8e7c-47d6-80fc-9c293cdd8acb?source=cve
- https://plugins.trac.wordpress.org/browser/wp-remote-users-sync/trunk/inc/class-wprus-logger.php#L117
- https://plugins.trac.wordpress.org/changeset/2946667/wp-remote-users-sync#file130
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2e87cfc4-8e7c-47d6-80fc-9c293cdd8acb?source=cve
Get alerted when CVE-2023-4374 or the next vulnerability affects your stack