What’s Vulnerable › Vulnerabilities
CVE-2023-4376: Serial Codes Generator and Validator with WooCommerce Support < 2.4.15 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-19 · updated 2026-06-17
Description
The Serial Codes Generator and Validator with WooCommerce Support WordPress plugin before 2.4.15 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)
Affected products
- Serial Codes Generator and Validator with WooCommerce Support: before 2.4.15 — fixed in 2.4.15
How to fix
Upgrade to a fixed version: Serial Codes Generator and Validator with WooCommerce Support 2.4.15. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/13910e52-5302-4252-8bee-49dd1f0e180a
- https://wpscan.com/vulnerability/13910e52-5302-4252-8bee-49dd1f0e180a
Get alerted when CVE-2023-4376 or the next vulnerability affects your stack