What’s Vulnerable › Vulnerabilities
CVE-2023-43771
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-22 · updated 2026-06-17
- Weakness: CWE-400
Description
In nqptp-message-handlers.c in nqptp before 1.2.3, crafted packets received on the control port could crash the program.
Affected products
- Mikebrady Not Quite Ptp: before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: Mikebrady Not Quite Ptp 1.2.3. Check the vendor advisory for mitigations.
References
- https://github.com/mikebrady/nqptp/commit/b24789982d5cc067ecf6e8f3352b701d177530ec
- https://github.com/mikebrady/nqptp/releases/tag/1.2.3
- https://github.com/mikebrady/nqptp/releases/tag/1.2.4
- https://github.com/mikebrady/nqptp/commit/b24789982d5cc067ecf6e8f3352b701d177530ec
- https://github.com/mikebrady/nqptp/releases/tag/1.2.3
- https://github.com/mikebrady/nqptp/releases/tag/1.2.4
Get alerted when CVE-2023-43771 or the next vulnerability affects your stack