What’s Vulnerable › Vulnerabilities

CVE-2023-4378: Insertion of Sensitive Information Into Sent Data in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions starting from 11.8 before 16.1.5, all versions starting from 16.2 before 16.2.5, all versions starting from 16.3 before 16.3.1. A malicious Maintainer can, under specific circumstances, leak the sentry token by changing the configured URL in the Sentry error tracking settings page. This was as a result of an incomplete fix for CVE-2022-4365.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.1.5, 16.2.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-4378 or the next vulnerability affects your stack