What’s Vulnerable › Vulnerabilities

CVE-2023-4379: Incorrect Authorization in GitLab

Description

An issue has been discovered in GitLab EE affecting all versions starting from 15.3 prior to 16.2.8, 16.3 prior to 16.3.5, and 16.4 prior to 16.4.1. Code owner approval was not removed from merge requests when the target branch was updated.

Affected products

How to fix

Upgrade to a fixed version: GitLab 16.2.8, 16.3.5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-4379 or the next vulnerability affects your stack