What’s Vulnerable › Vulnerabilities
CVE-2023-43795: WPS Server Side Request Forgery in GeoServer
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 69.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-25 · updated 2026-06-17
- Weakness: CWE-918
Description
GeoServer is an open source software server written in Java that allows users to share and edit geospatial data. The OGC Web Processing Service (WPS) specification is designed to process information from any server using GET and POST requests. This presents the opportunity for Server Side Request Forgery. This vulnerability has been patched in version 2.22.5 and 2.23.2.
Affected products
- geoserver org.geoserver.extension:gs-db2: before 2.22.5; from 2.23.0 before 2.23.2 — fixed in 2.22.5, 2.23.2
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.22.5, 2.23.2. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/security/advisories/GHSA-5pr3-m5hm-9956
- https://github.com/geoserver/geoserver/security/advisories/GHSA-5pr3-m5hm-9956
Get alerted when CVE-2023-43795 or the next vulnerability affects your stack