What’s Vulnerable › Vulnerabilities
CVE-2023-43814: Exposure of poll options and votes to unauthorized users in Discourse
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-200
Description
Discourse is an open source platform for community discussion. Attackers with details specific to a poll in a topic can use the `/polls/grouped_poll_results` endpoint to view the content of options in the poll and the number of votes for groups of poll participants. This impacts private polls where the results were intended to only be viewable by authorized users. This issue is patched in the 3.1.1 stable and 3.2.0.beta2 versions of Discourse. There is no workaround for this issue apart from upgrading to the fixed version.
Affected products
- discourse: through 3.1.1; 3.2.0-beta1
References
- https://github.com/discourse/discourse/security/advisories/GHSA-3x57-846g-7qcw
- https://github.com/discourse/discourse/security/advisories/GHSA-3x57-846g-7qcw
Get alerted when CVE-2023-43814 or the next vulnerability affects your stack