What’s Vulnerable › Vulnerabilities
CVE-2023-43826: Apache Guacamole: Integer overflow in handling of VNC image buffers
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-19 · updated 2026-06-17
- Weakness: CWE-190
Description
Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.
Affected products
- Apache Software Foundation Apache Guacamole: through 1.5.3
References
- http://www.openwall.com/lists/oss-security/2023/12/19/4
- https://lists.apache.org/thread/23gzwftpfgtq97tj6ttmbclry53kmwv6
- http://www.openwall.com/lists/oss-security/2023/12/19/4
- https://lists.apache.org/thread/23gzwftpfgtq97tj6ttmbclry53kmwv6
Get alerted when CVE-2023-43826 or the next vulnerability affects your stack