What’s Vulnerable › Vulnerabilities
CVE-2023-4395: Cross-site Scripting (XSS) - Stored in cockpit-hq/cockpit
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-08-17 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site Scripting (XSS) - Stored in GitHub repository cockpit-hq/cockpit prior to 2.6.4.
Affected products
- cockpit-hq/cockpit: before 2.6.4 — fixed in 2.6.4
How to fix
Upgrade to a fixed version: cockpit-hq/cockpit 2.6.4. Check the vendor advisory for mitigations.
References
- https://github.com/cockpit-hq/cockpit/commit/36d1d4d256cbbab028342ba10cc493e5c119172c
- https://huntr.dev/bounties/60e38563-7ac8-4a13-ac04-2980cc48b0da
- https://github.com/cockpit-hq/cockpit/commit/36d1d4d256cbbab028342ba10cc493e5c119172c
- https://huntr.dev/bounties/60e38563-7ac8-4a13-ac04-2980cc48b0da
Get alerted when CVE-2023-4395 or the next vulnerability affects your stack