What’s Vulnerable › Vulnerabilities
CVE-2023-4400
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-13 · updated 2026-06-17
- Weakness: CWE-256
Description
A password management vulnerability in Skyhigh Secure Web Gateway (SWG) in main releases 11.x prior to 11.2.14, 10.x prior to 10.2.25 and controlled release 12.x prior to 12.2.1, allows some authentication information stored in configuration files to be extracted through SWG REST API. This was possible due to SWG storing the password in plain text in some configuration files.
Affected products
- Skyhigh Security Skyhigh Secure Web Gateway (SWG): from 10.0.0 before 10.2.25; from 11.0.0 before 11.2.14; from 12.0.0 before 12.2.1 — fixed in 10.2.25, 11.2.14, 12.2.1
How to fix
Upgrade to a fixed version: Skyhigh Security Skyhigh Secure Web Gateway (SWG) 10.2.25, 11.2.14, 12.2.1. Check the vendor advisory for mitigations.
References
- https://kcm.trellix.com/corporate/index?page=content&id=SB10406
- https://github.com/advisories/GHSA-qggp-c2rq-6x65
- https://kcm.trellix.com/corporate/index?page=content&id=SB10406
Get alerted when CVE-2023-4400 or the next vulnerability affects your stack