What’s Vulnerable › Vulnerabilities
CVE-2023-4402: Essential Blocks <= 4.2.0 - Unauthenticated PHP Object Injection via products
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-10-20 · updated 2026-06-17
- Weakness: CWE-502
Description
The Essential Blocks plugin for WordPress is vulnerable to PHP Object Injection in versions up to, and including, 4.2.0 via deserialization of untrusted input in the get_products function. This allows unauthenticated attackers to inject a PHP Object. No POP chain is present in the vulnerable plugin. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
Affected products
- wpdevteam Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns: before 4.2.1 — fixed in 4.2.1
- wpdevteam Essential Blocks Pro: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: wpdevteam Gutenberg Essential Blocks – Page Builder for Gutenberg Blocks & Patterns 4.2.1; wpdevteam Essential Blocks Pro 1.1.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/essential-blocks/trunk/includes/API/Product.php?rev=2950425#L49
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1ede7a25-9bb2-408e-b7fb-e5bd4f594351?source=cve
- https://plugins.trac.wordpress.org/browser/essential-blocks/trunk/includes/API/Product.php?rev=2950425#L49
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1ede7a25-9bb2-408e-b7fb-e5bd4f594351?source=cve
Get alerted when CVE-2023-4402 or the next vulnerability affects your stack