What’s Vulnerable › Vulnerabilities
CVE-2023-44177: Junos OS and Junos OS Evolved: Stack overflow vulnerability in CLI command processing
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-13 · updated 2026-06-17
- Weakness: CWE-121
Description
A Stack-based Buffer Overflow vulnerability in the CLI command of Juniper Networks Junos and Junos EVO allows a low privileged attacker to execute a specific CLI commands leading to Denial of Service. Repeated actions by the attacker will create a sustained Denial of Service (DoS) condition. This issue affects Juniper Networks: Junos OS: * All versions prior to 19.1R3-S10; * 19.2 versions prior to 19.2R3-S7; * 19.3 versions prior to 19.3R3-S8; * 19.4 versions prior to 19.4R3-S12; * 20.2 versions prior to 20.2R3-S8; * 20.4 versions prior to 20.4R3-S8; * 21.2 versions prior to 21.2R3-S6; * 21.3 versions prior to 21.3R3-S5; * 21.4 versions prior to 21.4R3-S4; * 22.1 versions prior to 22.1R3-S3; * 22.2 versions prior to 22.2R3-S1; * 22.3 versions prior to 22.3R3; * 22.4 versions prior to 22.4R2. Junos OS Evolved: * All versions prior to 20.4R3-S8-EVO; * 21.2 versions prior to 21.2R3-S6-EVO; * 21.3 versions prior to 21.3R3-S5-EVO; * 21.4 versions prior to 21.4R3-S4-EVO; * 22.1 versions prior to 22.1R3-S3-EVO; * 22.2 versions prior to 22.2R3-S1-EVO; * 22.3 versions prior to 22.3R3-EVO; * 22.4 versions prior to 22.4R2-EVO.
Affected products
- Juniper Junos OS: before 20.4; 20.4, 20.4-r1, 20.4-r1-s1, 20.4-r2, 20.4-r2-s1, 20.4-r2-s2 (+69) — fixed in 20.4
- Juniper Networks Junos OS Evolved: before 20.4; 20.4, 20.4-r1, 20.4-r1-s1, 20.4-r1-s2, 20.4-r2, 20.4-r2-s1 (+68) — fixed in 20.4
How to fix
Upgrade to a fixed version: Juniper Junos OS 20.4; Juniper Networks Junos OS Evolved 20.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-44177 or the next vulnerability affects your stack