What’s Vulnerable › Vulnerabilities
CVE-2023-4423: WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce <= 3.1.37.1 - Authenticated (Admin+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via admin settings in versions up to, and including, 3.1.37.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- wpeventmanager WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce: before 3.1.38 — fixed in 3.1.38
How to fix
Upgrade to a fixed version: wpeventmanager WP Event Manager – Events Calendar, Registrations, Sell Tickets with WooCommerce 3.1.38. Check the vendor advisory for mitigations.
References
- https://github.com/Jacky-Y/vuls/blob/main/vul5.md
- https://github.com/wpeventmanager/wp-event-manager/issues/1483
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2969034%40wp-event-manager%2Ftrunk&old=2953169%40wp-event-manager%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dd9d22b0-a84a-4bf2-b8b4-89bae2970f29?source=cve
- https://github.com/Jacky-Y/vuls/blob/main/vul5.md
- https://github.com/wpeventmanager/wp-event-manager/issues/1483
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&new=2969034%40wp-event-manager%2Ftrunk&old=2953169%40wp-event-manager%2Ftrunk&sfp_email=&sfph_mail=
- https://www.wordfence.com/threat-intel/vulnerabilities/id/dd9d22b0-a84a-4bf2-b8b4-89bae2970f29?source=cve
Get alerted when CVE-2023-4423 or the next vulnerability affects your stack