What’s Vulnerable › Vulnerabilities
CVE-2023-44270: PostCSS line return parsing error
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-29 · updated 2026-06-17
- Weakness: CWE-74
Description
An issue was discovered in PostCSS before 8.4.31. The vulnerability affects linters using PostCSS to parse external untrusted CSS. An attacker can prepare CSS in such a way that it will contains parts parsed by PostCSS as a CSS comment. After processing by PostCSS, it will be included in the PostCSS output in CSS nodes (rules, properties) despite being included in a comment.
Affected products
- postcss: before 8.4.31 — fixed in 8.4.31
- Npm Postcss: before 8.4.31 — fixed in 8.4.31
How to fix
Upgrade to a fixed version: postcss 8.4.31; Npm Postcss 8.4.31. Check the vendor advisory for mitigations.
References
- https://github.com/github/advisory-database/issues/2820
- https://github.com/postcss/postcss/blob/main/lib/tokenize.js#L25
- https://github.com/postcss/postcss/commit/58cc860b4c1707510c9cd1bc1fa30b423a9ad6c5
- https://github.com/postcss/postcss/releases/tag/8.4.31
- https://github.com/github/advisory-database/issues/2820
- https://github.com/postcss/postcss/blob/main/lib/tokenize.js#L25
- https://github.com/postcss/postcss/commit/58cc860b4c1707510c9cd1bc1fa30b423a9ad6c5
- https://github.com/postcss/postcss/releases/tag/8.4.31
- https://lists.debian.org/debian-lts-announce/2024/12/msg00025.html
Get alerted when CVE-2023-44270 or the next vulnerability affects your stack