What’s Vulnerable › Vulnerabilities
CVE-2023-44273
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-28 · updated 2026-06-17
- Weakness: CWE-502
Description
Consensys gnark-crypto through 0.11.2 allows Signature Malleability. This occurs because deserialisation of EdDSA and ECDSA signatures does not ensure that the data is in a certain interval.
Affected products
- Consensys Gnark-Crypto: before 0.12.0 — fixed in 0.12.0
How to fix
Upgrade to a fixed version: Consensys Gnark-Crypto 0.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/Consensys/gnark-crypto/pull/449
- https://github.com/Consensys/gnark-crypto/releases
- https://verichains.io
- https://github.com/Consensys/gnark-crypto/pull/449
- https://github.com/Consensys/gnark-crypto/releases
- https://verichains.io
Get alerted when CVE-2023-44273 or the next vulnerability affects your stack