What’s Vulnerable › Vulnerabilities
CVE-2023-44284
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-14 · updated 2026-06-17
- Weakness: CWE-89
Description
Dell PowerProtect DD , versions prior to 7.13.0.10, LTS 7.7.5.25, LTS 7.10.1.15, 6.2.1.110 contain an SQL Injection vulnerability. A remote low privileged attacker could potentially exploit this vulnerability, leading to the execution of certain SQL commands on the application's backend database causing unauthorized read access to application data.
Affected products
- Dell Apex Protection Storage: before 6.2.1.110; from 7.0 before 7.10.1.15 — fixed in 6.2.1.110, 7.10.1.15
- EMC Data Domain OS 5.2 through 5.7 before 5.7.3.0 and 6.0 before 6.0.1.0: before 6.2.1.110; from 7.0 before 7.12.0.0; from 7.7 before 7.7.5.25; from 7.10 before 7.10.1.15 — fixed in 6.2.1.110, 7.10.1.15, 7.12.0.0, 7.7.5.25
- Dell Powerprotect Data Domain: before 6.2.1.110; from 7.0 before 7.12.0.0 — fixed in 6.2.1.110, 7.12.0.0
- Dell PowerProtect DD: before 6.2.1.110; from 7.0 before 7.13.0.10; from 7.7 before 7.7.5.25; from 7.10 before 7.10.1.15 — fixed in 6.2.1.110, 7.10.1.15, 7.13.0.10, 7.7.5.25
- Dell Powerprotect Data Protection: before 2.7.6 — fixed in 2.7.6
How to fix
Upgrade to a fixed version: Dell Apex Protection Storage 6.2.1.110, 7.10.1.15; EMC Data Domain OS 5.2 through 5.7 before 5.7.3.0 and 6.0 before 6.0.1.0 6.2.1.110, 7.10.1.15, 7.12.0.0, 7.7.5.25; Dell Powerprotect Data Domain 6.2.1.110, 7.12.0.0; Dell PowerProtect DD 6.2.1.110, 7.10.1.15, 7.13.0.10, 7.7.5.25; Dell Powerprotect Data Protection 2.7.6. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000220264/dsa-2023-412-dell-technologies-powerprotect-security-update-for-multiple-security-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000220264/dsa-2023-412-dell-technologies-powerprotect-security-update-for-multiple-security-vulnerabilities
Get alerted when CVE-2023-44284 or the next vulnerability affects your stack