What’s Vulnerable › Vulnerabilities
CVE-2023-44303
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-24 · updated 2026-06-17
- Weakness: CWE-310
Description
RVTools, Version 3.9.2 and above, contain a sensitive data exposure vulnerability in the password encryption utility (RVToolsPasswordEncryption.exe) and main application (RVTools.exe). A remote unauthenticated attacker with access to stored encrypted passwords from a users' system could potentially exploit this vulnerability, leading to the disclosure of encrypted passwords in clear text. This vulnerability is caused by an incomplete fix for CVE-2020-27688.
Affected products
- Robware Rvtools: from 3.9.2 before 4.5.0 — fixed in 4.5.0
How to fix
Upgrade to a fixed version: Robware Rvtools 4.5.0. Check the vendor advisory for mitigations.
References
- https://www.dell.com/support/kbdoc/en-us/000219712/dsa-2023-426-security-update-for-rvtools-vulnerabilities
- https://www.dell.com/support/kbdoc/en-us/000219712/dsa-2023-426-security-update-for-rvtools-vulnerabilities
Get alerted when CVE-2023-44303 or the next vulnerability affects your stack