What’s Vulnerable › Vulnerabilities

CVE-2023-44311

Description

Multiple reflected cross-site scripting (XSS) vulnerabilities in the Plugin for OAuth 2.0 module's OAuth2ProviderApplicationRedirect class in Liferay Portal 7.4.3.41 through 7.4.3.89, and Liferay DXP 7.4 update 41 through update 89 allow remote attackers to inject arbitrary web script or HTML via the (1) code, or (2) error parameter. This issue is caused by an incomplete fix in CVE-2023-33941.

Affected products

How to fix

Upgrade to a fixed version: Liferay Portal 7.4.3.90. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2023-44311 or the next vulnerability affects your stack