What’s Vulnerable › Vulnerabilities
CVE-2023-44312: Apache ServiceComb Service-Center: attacker can query all environment variables of the service-center server
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-31 · updated 2026-06-17
- Weakness: CWE-200
Description
Exposure of Sensitive Information to an Unauthorized Actor in Apache ServiceComb Service-Center.This issue affects Apache ServiceComb Service-Center before 2.1.0 (include). Users are recommended to upgrade to version 2.2.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache ServiceComb Service-Center: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache ServiceComb Service-Center 2.2.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/01/31/5
- https://lists.apache.org/thread/dkvlgnrmc17qzjdy9k0cr60wpzcssk1s
- http://www.openwall.com/lists/oss-security/2024/01/31/5
- https://lists.apache.org/thread/dkvlgnrmc17qzjdy9k0cr60wpzcssk1s
Get alerted when CVE-2023-44312 or the next vulnerability affects your stack