What’s Vulnerable › Vulnerabilities
CVE-2023-44313: Apache ServiceComb Service-Center: attacker can perform SSRF through the frontend API
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-31 · updated 2026-06-17
- Weakness: CWE-918
Description
Server-Side Request Forgery (SSRF) vulnerability in Apache ServiceComb Service-Center. Attackers can obtain sensitive server information through specially crafted requests.This issue affects Apache ServiceComb before 2.1.0(include). Users are recommended to upgrade to version 2.2.0, which fixes the issue.
Affected products
- Apache Software Foundation Apache ServiceComb Service-Center: before 2.2.0 — fixed in 2.2.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache ServiceComb Service-Center 2.2.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2024/01/31/4
- https://lists.apache.org/thread/kxovd455o9h4f2v811hcov2qknbwld5r
- http://www.openwall.com/lists/oss-security/2024/01/31/4
- https://lists.apache.org/thread/kxovd455o9h4f2v811hcov2qknbwld5r
Get alerted when CVE-2023-44313 or the next vulnerability affects your stack