What’s Vulnerable › Vulnerabilities
CVE-2023-44338: ZDI-CAN-21493: Adobe Acrobat Reader DC Annotation Out-Of-Bounds Read Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-16 · updated 2026-06-17
- Weakness: CWE-125
Description
Adobe Acrobat Reader versions 23.006.20360 (and earlier) and 20.005.30524 (and earlier) are affected by an out-of-bounds read vulnerability when parsing a crafted file, which could result in a read past the end of an allocated memory structure. An attacker could leverage this vulnerability to execute code in the context of the current user. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: from 20.001.30005 through 20.005.30539
- Adobe Acrobat DC: from 15.008.20082 before 23.006.20380 — fixed in 23.006.20380
- Adobe Acrobat Reader: from 20.001.30005 before 20.005.30539 — fixed in 20.005.30539
- Adobe Acrobat Reader: from 15.008.20082 before 23.006.20380 — fixed in 23.006.20380
How to fix
Upgrade to a fixed version: Adobe Acrobat DC 23.006.20380; Adobe Acrobat Reader 20.005.30539; Adobe Acrobat Reader 23.006.20380. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb23-54.htm
- https://helpx.adobe.com/security/products/acrobat/apsb23-54.htm
Get alerted when CVE-2023-44338 or the next vulnerability affects your stack