What’s Vulnerable › Vulnerabilities
CVE-2023-44378: gnark vulnerable to unsoundness in variable comparison/non-unique binary decomposition
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-09 · updated 2026-06-17
- Weakness: CWE-191
Description
gnark is a zk-SNARK library that offers a high-level API to design circuits. Prior to version 0.9.0, for some in-circuit values, it is possible to construct two valid decomposition to bits. In addition to the canonical decomposition of `a`, for small values there exists a second decomposition for `a+r` (where `r` is the modulus the values are being reduced by). The second decomposition was possible due to overflowing the field where the values are defined. Upgrading to version 0.9.0 should fix the issue without needing to change the calls to value comparison methods.
Affected products
- Consensys gnark: before 0.9.0 — fixed in 0.9.0
How to fix
Upgrade to a fixed version: Consensys gnark 0.9.0. Check the vendor advisory for mitigations.
References
- https://github.com/Consensys/gnark/commit/59a4087261a6c73f13e80d695c17b398c3d0934f
- https://github.com/Consensys/gnark/security/advisories/GHSA-498w-5j49-vqjg
- https://github.com/zkopru-network/zkopru/issues/116
- https://github.com/Consensys/gnark/commit/59a4087261a6c73f13e80d695c17b398c3d0934f
- https://github.com/Consensys/gnark/security/advisories/GHSA-498w-5j49-vqjg
- https://github.com/zkopru-network/zkopru/issues/116
Get alerted when CVE-2023-44378 or the next vulnerability affects your stack