What’s Vulnerable › Vulnerabilities
CVE-2023-44386: Incorrect request error handling triggers server crash in Vapor
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-05 · updated 2026-06-17
- Weakness: CWE-231
Description
Vapor is an HTTP web framework for Swift. There is a denial of service vulnerability impacting all users of affected versions of Vapor. The HTTP1 error handler closed connections when HTTP parse errors occur instead of passing them on. The issue is fixed as of Vapor release 4.84.2.
Affected products
- vapor: from 4.83.2 before 4.84.2 — fixed in 4.84.2
How to fix
Upgrade to a fixed version: vapor 4.84.2. Check the vendor advisory for mitigations.
References
- https://github.com/vapor/vapor/commit/090464a654b03148b139a81f8f5ac63b0856f6f3
- https://github.com/vapor/vapor/releases/tag/4.84.2
- https://github.com/vapor/vapor/security/advisories/GHSA-3mwq-h3g6-ffhm
- https://github.com/vapor/vapor/commit/090464a654b03148b139a81f8f5ac63b0856f6f3
- https://github.com/vapor/vapor/releases/tag/4.84.2
- https://github.com/vapor/vapor/security/advisories/GHSA-3mwq-h3g6-ffhm
Get alerted when CVE-2023-44386 or the next vulnerability affects your stack