What’s Vulnerable › Vulnerabilities
CVE-2023-44387: Gradle has incorrect permission assignment for symlinked files used in copy or archiving operations
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-05 · updated 2026-10-08
- Weakness: CWE-732
Description
Gradle is a build tool with a focus on build automation and support for multi-language development. When copying or archiving symlinked files, Gradle resolves them but applies the permissions of the symlink itself instead of the permissions of the linked file to the resulting file. This leads to files having too much permissions given that symlinks usually are world readable and writeable. While it is unlikely this results in a direct vulnerability for the impacted build, it may open up attack vectors depending on where build artifacts end up being copied to or un-archived. In versions 7.6.3, 8.4 and above, Gradle will now properly use the permissions of the file pointed at by the symlink to set permissions of the copied or archived file.
Affected products
- gradle: before 7.6.3; from 8.0.0 before 8.4.0 — fixed in 7.6.3, 8.4.0
How to fix
Upgrade to a fixed version: gradle 7.6.3, 8.4.0. Check the vendor advisory for mitigations.
References
- https://github.com/gradle/gradle/commit/3b406191e24d69e7e42dc3f3b5cc50625aa930b7
- https://github.com/gradle/gradle/releases/tag/v7.6.3
- https://github.com/gradle/gradle/releases/tag/v8.4.0
- https://github.com/gradle/gradle/security/advisories/GHSA-43r3-pqhv-f7h9
- https://security.netapp.com/advisory/ntap-20231110-0006/
- https://github.com/gradle/gradle/commit/3b406191e24d69e7e42dc3f3b5cc50625aa930b7
- https://github.com/gradle/gradle/releases/tag/v7.6.3
- https://github.com/gradle/gradle/releases/tag/v8.4.0
- https://github.com/gradle/gradle/security/advisories/GHSA-43r3-pqhv-f7h9
- https://security.netapp.com/advisory/ntap-20231110-0006/
Get alerted when CVE-2023-44387 or the next vulnerability affects your stack