What’s Vulnerable › Vulnerabilities
CVE-2023-44395: Autolab has Path Traversal vulnerability in Assessment functionality
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-01-22 · updated 2026-06-17
- Weakness: CWE-22
Description
Autolab is a course management service that enables instructors to offer autograded programming assignments to their students over the Web. Path traversal vulnerabilities were discovered in Autolab's assessment functionality in versions of Autolab prior to 2.12.0, whereby instructors can perform arbitrary file reads. Version 2.12.0 contains a patch. There are no feasible workarounds for this issue.
Affected products
- Autolab: before 2.12.0 — fixed in 2.12.0
How to fix
Upgrade to a fixed version: Autolab 2.12.0. Check the vendor advisory for mitigations.
References
- https://github.com/autolab/Autolab/releases/tag/v2.12.0
- https://github.com/autolab/Autolab/security/advisories/GHSA-h8wq-ghfq-5hfx
- https://www.stackhawk.com/blog/rails-path-traversal-guide-examples-and-prevention/
- https://github.com/autolab/Autolab/releases/tag/v2.12.0
- https://github.com/autolab/Autolab/security/advisories/GHSA-h8wq-ghfq-5hfx
- https://www.stackhawk.com/blog/rails-path-traversal-guide-examples-and-prevention/
Get alerted when CVE-2023-44395 or the next vulnerability affects your stack