What’s Vulnerable › Vulnerabilities
CVE-2023-44442: GIMP PSD File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 61.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-122
Description
GIMP PSD File Parsing Heap-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of PSD files. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a heap-based buffer. An attacker can leverage this vulnerability to execute arbitrary code in the context of the current process. Was ZDI-CAN-22094.
Affected products
- GIMP: before 2.10.36 — fixed in 2.10.36
How to fix
Upgrade to a fixed version: GIMP 2.10.36. Check the vendor advisory for mitigations.
References
- https://www.gimp.org/news/2023/11/07/gimp-2-10-36-released/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1594/
- https://lists.debian.org/debian-lts-announce/2023/11/msg00015.html
- https://www.gimp.org/news/2023/11/07/gimp-2-10-36-released/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1594/
Get alerted when CVE-2023-44442 or the next vulnerability affects your stack