What’s Vulnerable › Vulnerabilities
CVE-2023-44444: GIMP PSP File Parsing Off-By-One Remote Code Execution Vulnerability
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 56.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-193
Description
GIMP PSP File Parsing Off-By-One Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of GIMP. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the parsing of PSP files. Crafted data in a PSP file can trigger an off-by-one error when calculating a location to write within a heap-based buffer. An attacker can leverage this vulnerability to execute code in the context of the current process. . Was ZDI-CAN-22097.
Affected products
- GIMP: before 2.10.36 — fixed in 2.10.36
How to fix
Upgrade to a fixed version: GIMP 2.10.36. Check the vendor advisory for mitigations.
References
- https://www.gimp.org/news/2023/11/07/gimp-2-10-36-released/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1591/
- https://lists.debian.org/debian-lts-announce/2023/11/msg00015.html
- https://www.gimp.org/news/2023/11/07/gimp-2-10-36-released/
- https://www.zerodayinitiative.com/advisories/ZDI-23-1591/
Get alerted when CVE-2023-44444 or the next vulnerability affects your stack