What’s Vulnerable › Vulnerabilities
CVE-2023-44445: NETGEAR CAX30 SSO Stack-based Buffer Overflow Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-05-03 · updated 2026-06-17
- Weakness: CWE-121
Description
NETGEAR CAX30 SSO Stack-based Buffer Overflow Remote Code Execution Vulnerability. This vulnerability allows network-adjacent attackers to execute arbitrary code on affected installations of NETGEAR CAX30 routers. Authentication is not required to exploit this vulnerability. The specific flaw exists within the sso binary. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a fixed-length stack-based buffer. An attacker can leverage this vulnerability to execute code in the context of root. Was ZDI-CAN-19058.
Affected products
- NETGEAR CAX30: before 2.2.1.12 — fixed in 2.2.1.12
How to fix
Upgrade to a fixed version: NETGEAR CAX30 2.2.1.12. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000065859/Security-Advisory-for-Pre-authentication-Buffer-Overflow-on-the-CAX30-PSV-2023-0093
- https://www.zerodayinitiative.com/advisories/ZDI-23-1636/
- https://kb.netgear.com/000065859/Security-Advisory-for-Pre-authentication-Buffer-Overflow-on-the-CAX30-PSV-2023-0093
- https://www.zerodayinitiative.com/advisories/ZDI-23-1636/
Get alerted when CVE-2023-44445 or the next vulnerability affects your stack