What’s Vulnerable › Vulnerabilities
CVE-2023-44466
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 45.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-29 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in net/ceph/messenger_v2.c in the Linux kernel before 6.4.5. There is an integer signedness error, leading to a buffer overflow and remote code execution via HELLO or one of the AUTH frames. This occurs because of an untrusted length taken from a TCP packet in ceph_decode_32.
Affected products
- Linux kernel: from 5.11 before 5.15.121; from 5.16 before 6.1.40; from 6.2 before 6.4.5 — fixed in 5.15.121, 6.1.40, 6.4.5
How to fix
Upgrade to a fixed version: Linux kernel 5.15.121, 6.1.40, 6.4.5. Check the vendor advisory for mitigations.
References
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=a282a2f10539dce2aa619e71e1817570d557fc97
- https://github.com/google/security-research/security/advisories/GHSA-jg27-jx6w-xwph
- https://github.com/torvalds/linux/commit/a282a2f10539dce2aa619e71e1817570d557fc97
- https://security.netapp.com/advisory/ntap-20231116-0003/
- https://www.spinics.net/lists/ceph-devel/msg57909.html
- https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=a282a2f10539dce2aa619e71e1817570d557fc97
- https://github.com/google/security-research/security/advisories/GHSA-jg27-jx6w-xwph
- https://github.com/torvalds/linux/commit/a282a2f10539dce2aa619e71e1817570d557fc97
- https://security.netapp.com/advisory/ntap-20231116-0003/
- https://www.spinics.net/lists/ceph-devel/msg57909.html
Get alerted when CVE-2023-44466 or the next vulnerability affects your stack