What’s Vulnerable › Vulnerabilities
CVE-2023-44469
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-29 · updated 2026-06-17
- Weakness: CWE-918
Description
A Server-Side Request Forgery issue in the OpenID Connect Issuer in LemonLDAP::NG before 2.17.1 allows authenticated remote attackers to send GET requests to arbitrary URLs through the request_uri authorization parameter. This is similar to CVE-2020-10770.
Affected products
- lemonldap-ng Lemonldap::Ng: before 2.17.1 — fixed in 2.17.1
How to fix
Upgrade to a fixed version: lemonldap-ng Lemonldap::Ng 2.17.1. Check the vendor advisory for mitigations.
References
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/2998
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/releases/v2.17.1
- https://lists.debian.org/debian-lts-announce/2023/10/msg00014.html
- https://security.lauritz-holtmann.de/post/sso-security-ssrf/
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/issues/2998
- https://gitlab.ow2.org/lemonldap-ng/lemonldap-ng/-/releases/v2.17.1
- https://lists.debian.org/debian-lts-announce/2023/10/msg00014.html
- https://security.lauritz-holtmann.de/post/sso-security-ssrf/
Get alerted when CVE-2023-44469 or the next vulnerability affects your stack