What’s Vulnerable › Vulnerabilities
CVE-2023-44488
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-30 · updated 2026-06-17
- Weakness: CWE-755
Description
VP9 in libvpx before 1.13.1 mishandles widths, leading to a crash related to encoding.
Affected products
- Debian Linux: 10.0, 11.0, 12.0
- Fedoraproject Fedora: 37
- Red Hat Enterprise Linux: 8.0, 9.0
- Chromium libvpx: before 1.13.1 — fixed in 1.13.1
How to fix
Upgrade to a fixed version: Chromium libvpx 1.13.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/09/30/4
- https://bugzilla.redhat.com/show_bug.cgi?id=2241806
- https://github.com/webmproject/libvpx/commit/263682c9a29395055f3b3afe2d97be1828a6223f
- https://github.com/webmproject/libvpx/commit/df9fd9d5b7325060b2b921558a1eb20ca7880937
- https://github.com/webmproject/libvpx/compare/v1.13.0...v1.13.1
- https://github.com/webmproject/libvpx/releases/tag/v1.13.1
- https://lists.debian.org/debian-lts-announce/2023/10/msg00001.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/TE7F54W5O5RS4ZMAAC7YK3CZWQXIDSKB/
- https://security.gentoo.org/glsa/202310-04
- https://www.debian.org/security/2023/dsa-5518
- http://www.openwall.com/lists/oss-security/2023/09/30/4
- https://bugzilla.redhat.com/show_bug.cgi?id=2241806
Get alerted when CVE-2023-44488 or the next vulnerability affects your stack