What’s Vulnerable › Vulnerabilities
CVE-2023-4452: Web Server Buffer Overflow Vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-11-01 · updated 2026-06-17
- Weakness: CWE-120
Description
A vulnerability has been identified in the EDR-810, EDR-G902, and EDR-G903 Series, making them vulnerable to the denial-of-service vulnerability. This vulnerability stems from insufficient input validation in the URI, potentially enabling malicious users to trigger the device reboot.
Affected products
- Moxa Edr-810-2Gsfp-T Firmware: before 5.12.29 — fixed in 5.12.29
- Moxa Edr-810-2Gsfp Firmware: before 5.12.29 — fixed in 5.12.29
- Moxa Edr-810-Vpn-2Gsfp-T Firmware: before 5.12.29 — fixed in 5.12.29
- Moxa Edr-810-Vpn-2Gsfp Firmware: before 5.12.29 — fixed in 5.12.29
- Moxa Edr-G902-T Firmware: before 5.7.21 — fixed in 5.7.21
- Moxa Edr-G902 Firmware: before 5.7.21 — fixed in 5.7.21
- Moxa Edr-G903-T Firmware: before 5.7.21 — fixed in 5.7.21
- Moxa Edr-G903 Firmware: before 5.7.21 — fixed in 5.7.21
How to fix
Upgrade to a fixed version: Moxa Edr-810-2Gsfp-T Firmware 5.12.29; Moxa Edr-810-2Gsfp Firmware 5.12.29; Moxa Edr-810-Vpn-2Gsfp-T Firmware 5.12.29; Moxa Edr-810-Vpn-2Gsfp Firmware 5.12.29; Moxa Edr-G902-T Firmware 5.7.21; Moxa Edr-G902 Firmware 5.7.21; Moxa Edr-G903-T Firmware 5.7.21; Moxa Edr-G903 Firmware 5.7.21. Check the vendor advisory for mitigations.
References
- https://www.moxa.com/en/support/product-support/security-advisory/mpsa-234880-edr-810-g902-g903-series-web-server-buffer-overflow-vulnerability
- https://www.moxa.com/en/support/product-support/security-advisory/mpsa-234880-edr-810-g902-g903-series-web-server-buffer-overflow-vulnerability
Get alerted when CVE-2023-4452 or the next vulnerability affects your stack