What’s Vulnerable › Vulnerabilities
CVE-2023-4458: Kernel: ksmbd: smb2_open out-of-bounds read information disclosure vulnerability
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-10-02
- Weakness: CWE-125
Description
A flaw was found within the parsing of extended attributes in the kernel ksmbd module. The issue results from the lack of proper validation of user-supplied data, which can result in a read past the end of an allocated buffer. An attacker can leverage this to disclose sensitive information on affected installations of Linux. Only systems with ksmbd enabled are vulnerable to this CVE.
Affected products
- Linux kernel: before 5.15.131; from 5.16 before 6.1.52; from 6.2 before 6.4.15; from 6.5 before 6.5.2 — fixed in 5.15.131, 6.1.52, 6.4.15, 6.5.2
How to fix
Upgrade to a fixed version: Linux kernel 5.15.131, 6.1.52, 6.4.15, 6.5.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/security/cve/CVE-2023-4458
- https://bugzilla.redhat.com/show_bug.cgi?id=2325516
- https://www.zerodayinitiative.com/advisories/ZDI-24-590/
Get alerted when CVE-2023-4458 or the next vulnerability affects your stack