What’s Vulnerable › Vulnerabilities
CVE-2023-44796
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-11-18 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross Site Scripting (XSS) vulnerability in LimeSurvey before version 6.2.9-230925 allows a remote attacker to escalate privileges via a crafted script to the _generaloptions_panel.php component.
Affected products
- LimeSurvey: before 6.2.9 — fixed in 6.2.9
How to fix
Upgrade to a fixed version: LimeSurvey 6.2.9. Check the vendor advisory for mitigations.
References
- https://github.com/Hebing123/CVE-2023-44796/issues/1
- https://github.com/Hebing123/cve/issues/4
- https://github.com/LimeSurvey/LimeSurvey/pull/3483
- https://github.com/limesurvey/limesurvey/commit/135511073c51c332613dd7fad9a8ca0aad34a3fe
- https://github.com/Hebing123/CVE-2023-44796/issues/1
- https://github.com/Hebing123/cve/issues/4
- https://github.com/LimeSurvey/LimeSurvey/pull/3483
- https://github.com/limesurvey/limesurvey/commit/135511073c51c332613dd7fad9a8ca0aad34a3fe
Get alerted when CVE-2023-44796 or the next vulnerability affects your stack