What’s Vulnerable › Vulnerabilities
CVE-2023-44981: Apache ZooKeeper: Authorization bypass in SASL Quorum Peer Authentication
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-11 · updated 2026-06-17
- Weakness: CWE-639
Description
Authorization Bypass Through User-Controlled Key vulnerability in Apache ZooKeeper. If SASL Quorum Peer authentication is enabled in ZooKeeper (quorum.auth.enableSasl=true), the authorization is done by verifying that the instance part in SASL authentication ID is listed in zoo.cfg server list. The instance part in SASL auth ID is optional and if it's missing, like 'eve@EXAMPLE.COM', the authorization check will be skipped. As a result an arbitrary endpoint could join the cluster and begin propagating counterfeit changes to the leader, essentially giving it complete read-write access to the data tree. Quorum Peer authentication is not enabled by default. Users are recommended to upgrade to version 3.9.1, 3.8.3, 3.7.2, which fixes the issue. Alternately ensure the ensemble election/quorum communication is protected by a firewall as this will mitigate the issue. See the documentation for more details on correct cluster administration.
Affected products
- Apache Software Foundation Apache ZooKeeper: before 3.7.2; from 3.8.0 before 3.8.3; 3.9.0 — fixed in 3.7.2, 3.8.3
- Debian Linux: 10.0, 11.0, 12.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache ZooKeeper 3.7.2, 3.8.3. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2023/10/11/4
- https://lists.apache.org/thread/wf0yrk84dg1942z1o74kd8nycg6pgm5b
- https://lists.debian.org/debian-lts-announce/2023/10/msg00029.html
- https://security.netapp.com/advisory/ntap-20240621-0007/
- https://www.debian.org/security/2023/dsa-5544
- http://www.openwall.com/lists/oss-security/2023/10/11/4
- https://lists.apache.org/thread/wf0yrk84dg1942z1o74kd8nycg6pgm5b
- https://lists.debian.org/debian-lts-announce/2023/10/msg00029.html
- https://security.netapp.com/advisory/ntap-20240621-0007/
- https://www.debian.org/security/2023/dsa-5544
Get alerted when CVE-2023-44981 or the next vulnerability affects your stack