What’s Vulnerable › Vulnerabilities
CVE-2023-4502: Translate WordPress with GTranslate < 3.0.4 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-25 · updated 2026-06-17
Description
The Translate WordPress with GTranslate WordPress plugin before 3.0.4 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup). This vulnerability affects multiple parameters.
Affected products
- Translate WordPress with GTranslate: before 3.0.4 — fixed in 3.0.4
How to fix
Upgrade to a fixed version: Translate WordPress with GTranslate 3.0.4. Check the vendor advisory for mitigations.
References
- https://wpscan.com/vulnerability/e4804850-2ac2-4cec-bc27-07ed191d96da
- https://wpscan.com/vulnerability/e4804850-2ac2-4cec-bc27-07ed191d96da
Get alerted when CVE-2023-4502 or the next vulnerability affects your stack