What’s Vulnerable › Vulnerabilities
CVE-2023-4504: OpenPrinting CUPS/libppd Postscript Parsing Heap Overflow
- Severity: high (CVSS 7.0 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2023-09-21 · updated 2026-06-17
- Weakness: CWE-122
Description
Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.
Affected products
- Debian Linux: 10.0
- Fedoraproject Fedora: 37, 38, 39
- OpenPrinting cups: before 2.4.7 — fixed in 2.4.7
- OpenPrinting libppd: 2.0-rc2
How to fix
Upgrade to a fixed version: OpenPrinting cups 2.4.7. Check the vendor advisory for mitigations.
References
- https://github.com/OpenPrinting/cups/releases/tag/v2.4.7
- https://github.com/OpenPrinting/cups/security/advisories/GHSA-pf5r-86w9-678h
- https://github.com/OpenPrinting/libppd/security/advisories/GHSA-4f65-6ph5-qwh6
- https://lists.debian.org/debian-lts-announce/2023/09/msg00041.html
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5WHEJIYMMAIXU2EC35MGTB5LGGO2FFJE/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/5WVS4I7JG3LISFPKTM6ADKJXXEPEEWBQ/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/AMYDKIE4PSJDEMC5OWNFCDMHFGLJ57XG/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PXPVADB56NMLJWG4IZ3OZBNJ2ZOLPQJ6/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/T2GSPQAFK2Z6L57TRXEKZDF42K2EVBH7/
- https://takeonme.org/cves/CVE-2023-4504.html
- http://seclists.org/fulldisclosure/2024/Sep/33
- https://github.com/OpenPrinting/cups/releases/tag/v2.4.7
Get alerted when CVE-2023-4504 or the next vulnerability affects your stack