What’s Vulnerable › Vulnerabilities
CVE-2023-45083: HyperCloud: "admin" and "serveradmin" users can be deleted
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-12-05 · updated 2026-06-17
- Weakness: CWE-269
Description
An Improper Privilege Management vulnerability exists in HyperCloud that will impact the ability for a user to authenticate against the management plane. An authenticated admin-level user may be able to delete the "admin" or "serveradmin" users, which prevents authentication from subsequently succeeding. This issue affects HyperCloud versions 1.0 to any release before 2.1.
Affected products
- SoftIron HyperCloud: from 1.0 before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: SoftIron HyperCloud 2.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2023-45083 or the next vulnerability affects your stack