What’s Vulnerable › Vulnerabilities
CVE-2023-45128: CSRF Token Reuse Vulnerability in fiber
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-16 · updated 2026-06-17
- Weakness: CWE-20
Description
Fiber is an express inspired web framework written in Go. A Cross-Site Request Forgery (CSRF) vulnerability has been identified in the application, which allows an attacker to inject arbitrary values and forge malicious requests on behalf of a user. This vulnerability can allow an attacker to inject arbitrary values without any authentication, or perform various malicious actions on behalf of an authenticated user, potentially compromising the security and integrity of the application. The vulnerability is caused by improper validation and enforcement of CSRF tokens within the application. This issue has been addressed in version 2.50.0 and users are advised to upgrade. Users should take additional security measures like captchas or Two-Factor Authentication (2FA) and set Session cookies with SameSite=Lax or SameSite=Secure, and the Secure and HttpOnly attributes as defense in depth measures. There are no known workarounds for this vulnerability.
Affected products
- gofiber fiber: before 2.50.0 — fixed in 2.50.0
How to fix
Upgrade to a fixed version: gofiber fiber 2.50.0. Check the vendor advisory for mitigations.
References
- https://github.com/gofiber/fiber/commit/8c3916dbf4ad2ed427d02c6eb63ae8b2fa8f019a
- https://github.com/gofiber/fiber/security/advisories/GHSA-94w9-97p3-p368
- https://github.com/gofiber/fiber/commit/8c3916dbf4ad2ed427d02c6eb63ae8b2fa8f019a
- https://github.com/gofiber/fiber/security/advisories/GHSA-94w9-97p3-p368
Get alerted when CVE-2023-45128 or the next vulnerability affects your stack