What’s Vulnerable › Vulnerabilities
CVE-2023-45129: matrix-synapse vulnerable to denial of service due to malicious server ACL events
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-10-10 · updated 2026-06-17
- Weakness: CWE-770
Description
Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. Prior to version 1.94.0, a malicious server ACL event can impact performance temporarily or permanently leading to a persistent denial of service. Homeservers running on a closed federation (which presumably do not need to use server ACLs) are not affected. Server administrators are advised to upgrade to Synapse 1.94.0 or later. As a workaround, rooms with malicious server ACL events can be purged and blocked using the admin API.
Affected products
- Fedoraproject Fedora: 37, 38
- matrix-org synapse: before 1.94.0 — fixed in 1.94.0
How to fix
Upgrade to a fixed version: matrix-org synapse 1.94.0. Check the vendor advisory for mitigations.
References
- https://github.com/matrix-org/synapse/pull/16360
- https://github.com/matrix-org/synapse/security/advisories/GHSA-5chr-wjw5-3gq4
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KEVRB4MG5UXQ5RLZHSUJXM5GWEBYYS5B/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/N6P4QULVUE254WI7XF2LWWOGHCYVFXFY/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WRO4MPQ6HOXIUZM6RJP6VTCTMV7RD2T3/
- https://matrix-org.github.io/synapse/latest/admin_api/rooms.html#version-2-new-version
- https://security.gentoo.org/glsa/202401-12
- https://github.com/matrix-org/synapse/pull/16360
- https://github.com/matrix-org/synapse/security/advisories/GHSA-5chr-wjw5-3gq4
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/KEVRB4MG5UXQ5RLZHSUJXM5GWEBYYS5B/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/N6P4QULVUE254WI7XF2LWWOGHCYVFXFY/
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/WRO4MPQ6HOXIUZM6RJP6VTCTMV7RD2T3/
Get alerted when CVE-2023-45129 or the next vulnerability affects your stack